[Winpcap-users] Winpcap 4.0.2, Windows Vista (Business edition & SP1)

Eddie Ehlin eddie.ehlin at vastgotadata.se
Fri Nov 28 12:57:24 GMT 2008


I have received a new laptop at work, preinstalled with Windows Vista 
Business Edition SP1, and when I tried to run my application it just 
hangs. I'm unable to kill the process, so the only way to return to 
square one is by rebooting the actual machine. My application runs 
without any problems under Windows XP (SP3) with version 4.0.2.

I did some investigation and I managed to figure out that it seems to be 
related to pcap_sendpacket; pcap_sendpacket just hangs and never 
returns. Same state occur when I run the example program sendpack 
(Examples-pcap/sendpack) - it just hangs..

Development enviroment:
Winpcap: 4.0.2 (with one little change in pcap-stdinc.h at 63: //#define 
vsnprintf _vsnprintf ) Unable to compile without it.
MS Visual studio 2008
Language used: C++

Network interface (output from iflist example):
        Description: Broadcom NetXtreme Gigabit Ethernet Driver
        Loopback: no
        Address Family: #23
        Address Family Name: AF_INET6
        Address: fe80::dc34:ca35:7142:b505%13
        Address Family: #2
        Address Family Name: AF_INET
        Broadcast Address:

Thanks in advance!

Best regards,

More information about the Winpcap-users mailing list