[Winpcap-users] DLink DWA643 support - promiscuous mode

Justin Kremer j at justinkremer.com
Sat Jul 18 18:11:37 PDT 2009

I'm having issues using my D-Link DWA-643 with WireShark and a variety of
other programs which use WinPcap.  In WireShark, I get the "failed to set
hardware filter to promiscuous mode" message.  I reviewed the documentation
on the WinPcap website which suggests using WinDump for troubleshooting;
this gives me the same error "windump: failed to set hardware filter to
promiscuous mode".  What is odd is that this card works fine with CommView!
I have tried WinPcap with the OEM driver and CommView-modified driver, both
yield the same error.  If the card is able to go into promiscuous mode in
CommView, why wouldn't it do it with WinPcap???

TIA for any assistance,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winpcap.org/pipermail/winpcap-users/attachments/20090718/cd59e119/attachment.htm 

More information about the Winpcap-users mailing list