[Winpcap-users] Error Starting NPF

Fish fish at infidels.org
Tue May 26 20:34:23 PDT 2009

Hash: SHA1

I am not saying this is what the problem is, but I can state that I
personally experienced this very issue a long time ago whenever I
first began playing around with x64. In my particular case it was x64
windows complaining that the driver it was trying to load was not a
64-bit driver. Somehow things got setup such that the 32-bit driver
was always trying to be loaded which does not work on 64-bit Windows.
On 64-bit Windows all drivers must be 64-bit. Either that or the
opposite: a 64-bit driver was trying to be loaded by 32-bit Windows.

Again, I'm not stating that is your problem, only that the "Driver
has been blocked from loading" error message you mention was
experienced by myself for the reasons described.

Hope that helps.

- --
"Fish" (David B. Trout) - fish at softdevlabs.com
Fight Spam! Join CAUCE! <http://www.cauce.org/>
7 reasons why HTML email is a bad thing
PGP key fingerprints:
RSA: 6B37 7110 7201 9917 9B0D 99E3 55DB 5D58 FADE 4A52
DH/DSS: 9F9B BAB0 BA7F C458 1A89 FE26 48F5 D7F4 C4EE 3E2A

  -----Original Message-----
  From: winpcap-users-bounces at winpcap.org
[mailto:winpcap-users-bounces at winpcap.org]On Behalf Of Andy Merrill
  Sent: Tuesday, May 26, 2009 10:49 AM
  To: winpcap-users at winpcap.org
  Subject: [Winpcap-users] Error Starting NPF

  I'm getting an odd error when I try to run WireShark. So I started
doing some digging and found that WinPcap 4.0.2 is not starting up. 
I've used it plenty of times in the past on other systems, but on
this specific box I get an error in the Event Logs that says:

  "The NetGroup Packet Filter Driver service failed to start due to
the following error: 
  This driver has been blocked from loading "

  So I tried to start it via command line with "net start npf" and
got pretty much the same error of:

  "System error 1275 has occurred.

  This driver has been blocked from loading"

  Anyone have an idea why the drivers might be failing to load?

  This is on a Windows Server 2003 system running in a VPS. 

  Andy Merrill

Version: PGP 8.1

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGPexch.htm.pgp
Type: application/octet-stream
Size: 1915 bytes
Desc: not available
Url : http://www.winpcap.org/pipermail/winpcap-users/attachments/20090526/7af27e2b/attachment.obj 

More information about the Winpcap-users mailing list