[Winpcap-users] Windows 7 Pro x64 RE Install Fails

Mark Pizzolato - WinPCap-Users winpcap-users-20040408 at subscriptions.pizzolato.net
Sun Jan 8 17:00:29 PST 2012

I'm not sure what you are trying to determine.

Ø  Sc qc npf

Returns the configuration for the npf service

Ø  Net start npf

Starts the npf service.
Clearly these are NOT the same thing.

Ø  Sc start npf

would be the same as "net start npf"

Something is clearly tangled up on the system which doesn't work.  Winpcap works for me (and MANY other folks) on MANY Win7 x64 systems without any problem.

Even though you've had control of the affected system since it shipped, something that happened to the system while you've had control of it has created this tangle.

I hate to suggest restoring the system to the condition it shipped in would likely make things work, but that may be what you need to do....

Good Luck.

From: winpcap-users-bounces at winpcap.org [mailto:winpcap-users-bounces at winpcap.org] On Behalf Of Fred Marshall
Sent: Sunday, January 08, 2012 4:31 PM
To: winpcap-users at winpcap.org
Subject: Re: [Winpcap-users] Windows 7 Pro x64 RE Install Fails

I've had control of this system since it was shipped .. basically.
I have another Window 7 64 system that works fine - uses the same antivirus too.

Today I figured out that the npf.sys driver must be a problem.

On the troubled system, I ran
sc qc npf
and get a good report.
So it seems the file is "there".....

If I run:
sc config npf start= auto
there is no complaint; yet, it doesn't seem to do anything in a reboot.

If I run
net start npf
I get Syhstem error 2 has occurred
The system cannot find the file specified. !!!!!!

So, it appears there is a difference between
sc qc npf
net start npf

I've also looked at the ... well I can't find the full steps but it's like in the not plugnplay, hidden, etc.
and it's not showing there.......

Everything has been run as Administrator, etc.

On 1/5/2012 4:45 PM, "Fish" (David B. Trout) wrote:

Fred Marshall wrote:

This problem persists and I've not found a solution.

Is there any way to install WinPcap on Windows 7 x64???

I've installed it many times on my Windows 7 x64 system without any problem

whatsoever. So have many others. There is obviously something unique about

your particular system that you need to figure out.

Did you perchance change the permissions of your system drive (the Program

Files directory)? Or change the permissions of your Registry? Did you maybe

disable some critical Windows service or something? Have you tried

COMPLETELY uninstalling your anti-virus? (just as a test)

You (or someone else) obviously changed something on your system to prevent

the installation of WinPCap from succeeding, and you need to figure out what

that something was.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winpcap.org/pipermail/winpcap-users/attachments/20120108/eedd6681/attachment.html>

More information about the Winpcap-users mailing list