The problem is acutally solved. I now listen on all interfaces in separate threads, and am getting the expected results.<br><br>Thank you for your help,<div><br></div><div>Yvan<br><br><div class="gmail_quote">2011/2/4 Gianluca Varenni <span dir="ltr"><<a href="mailto:Gianluca.Varenni@riverbed.com">Gianluca.Varenni@riverbed.com</a>></span><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div bgcolor="white" lang="EN-US" link="blue" vlink="purple"><div><p class="MsoNormal"><span style="font-size:11.0pt;color:#1F497D">Anton,</span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;color:#1F497D">†</span></p><p class="MsoNormal"><span style="font-size:11.0pt;color:#1F497D">Iím a bit confused.</span></p><p class="MsoNormal"><span style="font-size:11.0pt;color:#1F497D">The original email was from Yvan and was reporting an issue by which no packets were captured. Here you talk about packets delivered only after a timeout. Did you reply to the wrong email thread?</span></p>
<div class="im"><p class="MsoNormal"><span style="font-size:11.0pt;color:#1F497D">†</span></p><p class="MsoNormal"><span style="font-size:11.0pt;color:#1F497D">Have a nice day</span></p><p class="MsoNormal"><span style="font-size:11.0pt;color:#1F497D">GV</span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;color:#1F497D">†</span></p></div><div><div style="border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in"><p class="MsoNormal"><b><span style="font-size:10.0pt;color:windowtext">From:</span></b><span style="font-size:10.0pt;color:windowtext"> Anton Tremsin [mailto:<a href="mailto:ast@ssl.berkeley.edu" target="_blank">ast@ssl.berkeley.edu</a>] <br>
<b>Sent:</b> Monday, January 31, 2011 11:44 PM</span></p><div class="im"><br><b>To:</b> <a href="mailto:winpcap-users@winpcap.org" target="_blank">winpcap-users@winpcap.org</a><br></div><b>Cc:</b> Gianluca Varenni<br><b>Subject:</b> Re: [Winpcap-users] Windows 7 Not capturing anything<p>
</p></div></div><div><div></div><div class="h5"><p class="MsoNormal">†</p><p class="MsoNormal">Yes my adapter is there, I can look at the packets in Wireshark and in my C code. See packets missed in Wireshark, in my code they arrive after the timeout.<br>
<br>Thanks,<br><br>Anton<br><br>Gianluca Varenni wrote: </p><div><p>Is your adapter listed by Wireshark and/or Windump? </p><p>† </p><p>Have a nice day </p><p>GV </p><p>† </p><p><b>From:</b> <a href="mailto:winpcap-users-bounces@winpcap.org" target="_blank">winpcap-users-bounces@winpcap.org</a> [<a href="mailto:winpcap-users-bounces@winpcap.org" target="_blank">mailto:winpcap-users-bounces@winpcap.org</a>] <b>On Behalf Of </b>Yvan Janssens<br>
<b>Sent:</b> Sunday, January 30, 2011 8:51 AM<br><b>To:</b> <a href="mailto:winpcap-users@winpcap.org" target="_blank">winpcap-users@winpcap.org</a><br><b>Subject:</b> [Winpcap-users] Windows 7 Not capturing anything </p>
<p>† </p><p>Hi, </p><div><p>† </p></div><div><p>I'm on a Windows 7 machine, and my app doesn't capture any packets. I'm using the latest version of WinPCAP (4.1.2 if I recall corectly). The strange thing is, WinDump doesn't work too. Are there special things I need to do, before capturing? </p>
</div><div><p>† </p></div><div><p>Do I need to run the app as Administrator? (that didn't help neither...) </p></div><div><p>† </p></div><div><p>Thank you! </p></div><div><p>† </p></div><div><p>Yvan JANSSENS<br><br>-- <br>
Never be afraid to try something new. Remember amateurs built the ark - Professionals built the Titanic. </p></div></div><pre>†</pre><pre>†</pre><pre>_______________________________________________</pre><pre>Winpcap-users mailing list</pre>
<pre><a href="mailto:Winpcap-users@winpcap.org" target="_blank">Winpcap-users@winpcap.org</a></pre><pre><a href="https://www.winpcap.org/mailman/listinfo/winpcap-users" target="_blank">https://www.winpcap.org/mailman/listinfo/winpcap-users</a></pre>
<pre>† </pre><p class="MsoNormal">†</p></div></div></div></div><br>_______________________________________________<br>
Winpcap-users mailing list<br>
<a href="mailto:Winpcap-users@winpcap.org">Winpcap-users@winpcap.org</a><br>
<a href="https://www.winpcap.org/mailman/listinfo/winpcap-users" target="_blank">https://www.winpcap.org/mailman/listinfo/winpcap-users</a><br>
<br></blockquote></div><br><br clear="all"><br>-- <br><span style="font-family:Arial, sans-serif">Never be afraid to try something new. Remember amateurs built the ark - Professionals built the Titanic.</span><br>
</div>