AW: [Winpcap-users] winpcap device list "emtpy"

Michael Marschalkowski grinch at
Wed Nov 29 07:53:26 GMT 2006

No, first I did a reinstall of 3.1, changed nothing. Then I installed 4.0b2,
the name of the generic dialup adapter changed, but still no other devices
I don't get any error messages, neither on installation or deinstallation
nor when I run my program or WinDump, they just don't list the devices.

I've just checked the antivirus log, but no virus found since installation
(4 months ago). ATM winpcap3.1 is installed and a very deep virus scan is
running with logging set to high, but this could take a while ;)
AntiVirus Software installed is VirusScan Enterprise 8.0.0 (McAfee).

Is there any registry value or something that pcap checks to filter the
device list? 


-----Ursprüngliche Nachricht-----
Von: winpcap-users-bounces at
[mailto:winpcap-users-bounces at] Im Auftrag von Gianluca Varenni
Gesendet: Dienstag, 28. November 2006 17:25
An: winpcap-users at
Betreff: Re: [Winpcap-users] winpcap device list "emtpy"

Did the reinstallation fix the problem?

If so, it's definitely possible that some update or some
antivirus/malware/... software decided that the winpcap driver (npf.sys) was
bad and removed it.

Have a nice day

----- Original Message -----
From: "Michael Marschalkowski" <grinch at>
To: <winpcap-users at>
Sent: Tuesday, November 28, 2006 12:53 AM
Subject: [Winpcap-users] winpcap device list "emtpy"

> Hi,
> this is my first post on this mailinglist and I guess/hope it's only a
> little problem to solve.
> I've written a little program that monitors a Windows 2003 EE SP1 (traffic
> accounting). The server has 2 real network cards and 1 TAP device 
> (OpenVPN).
> But since Nov 24 it does not list those devices (retrieved by
> pcap_findalldevs). The only device listed is the "generic dialup adapter"
> (winpcap 3.1) or "Adapter for generic dialup and VPN capture" (4.0b2).
> WinDump -D also only lists this device, so I think this is not a problem
> with my program but something is wrong with winpcap.
> I'm not Adminstrator of this machine (but I do have Administrator rights, 
> so
> that's not the problem :)), so I can't really tell what was done. The 
> person
> responsible for this server only told me, that he did some (all?) updates
> and since then the program refused to start. He gave me a little list with
> the installed updates, maybe that is useful to you:
> KB922582
> KB920213
> KB922819
> KB923191
> KB923414
> KB923980
> KB924191
> KB917537
> KB920685
> Before those updates winpcap worked fine and listed all devices.
> What I've done for now is reinstalling WinPcap 3.1 and installing WinPcap
> 4.0b2. The network cards are running and IPs are configured (I'm accessing
> the server via RDP).
> Any ideas? What went wrong or better, how do I fix it ;)
> If you need more information, let me know.
> best regards
> Michael
> _______________________________________________
> Winpcap-users mailing list
> Winpcap-users at

Winpcap-users mailing list
Winpcap-users at

More information about the Winpcap-users mailing list