[Winpcap-users] WinPCap dropping packets UNLESS USB device plugged in?

Frame, Jerry Jerry.Frame at disney.com
Thu Jan 20 05:51:21 PST 2011

I've ran into a very odd situation with WinPCap 4.1.2.  I have a several quad core HP computers running a WinPCap based application that sends a broadcast UDP message at 10hz.  For some reason on these HP machines, instead of the broadcast (192.168.x.255) coming out of the NIC at 10hz, the traffic only seems to be at 1-3hz (this is displayed on our embedded system.)  If I run Wireshark on the local HP PC though, I clearly see a packet every 100 ms.  However, if I run Wireshark on another PC connected to the same network, it confirms the 1-3 hz issue.  Here's the really strange thing.  If I plug in a USB drive, or a USB network adapter (even though I'm not using it), the broadcast starts working normally (10 hz).  Unplug the USB device, and it drops back down.  I ran a test application that uses basic Winsock (the Delphi Indy components to be exact), and it always seems to work fine.

Any suggestions are greatly appreciated.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winpcap.org/pipermail/winpcap-users/attachments/20110120/f27768f8/attachment.html>

More information about the Winpcap-users mailing list